Thursday, April 19, 2007

Update Verizon Firmware by 07/15/2007 to avoid service interruption

Update Verizon Firmware by 07/15/2007 to avoid EVDO service interruption

Verizon Wireless is sending out a large postcard to existing customers letting them know that if they don't upgrade the firmware of specific EVDO devices, their service may stop working on 07/15/2007.

This affects the following devices:

  • Kyocera KPC650 - Requires firmware CG 1.0.06
  • Verizon Wireless V620 - Requires Version M6500 C-BBIRD_VZW_PCCARD-40306.156
    -OR- Version M6500C-BBIRD-40304.135
  • Verizon Wireless XV6600 phone
Don't be alarmed this usually only affects data cards purchased before 12/31/2005. If you purchased a KPC650 from us before 12/31/2005 and use your KPC650 in a Mac or Router and you do not have access to a Windows computer to do the firmware upgrade - we offer a mail-in upgrade to perform the upgrade for you.

Related Links: